Related Products

Contents

Windows

Install Node.js

The Mobify Client runs a local web server with the development copy of your Mobify bundle. It uses Node.js to run this web server. Version 0.8.21 or newer is required.

Download the latest Node.js here

Logout or restart your computer after installing Node to continue.

Open the command prompt

Click on the Start button, or in Windows Vista / 7 click on the Windows logo button in your taskbar.

In the search bar, type:

cmd

and hit Enter.

Install Mobify Enterprise Client

Use npm to install the Mobify Enterprise Client on your computer

npm -g install mobify-client

Troubleshooting

If the installation fails, you may need to run the command prompt as an Administrator. To do this, right-click on the command prompt icon and choose the "Run as Administrator" menu option.

Recommended Tools

We use the following tools internally at Mobify and recommend them for your development process as well. However, they are not required to develop with Mobify Enterprise Client.

Ruby

Compass requires Ruby. Version 1.87 or newer is required.

Grab the latest Ruby package here

NOTE: Make sure to select 'Add ruby to your path during the installation'

Compass/Sass

The Mobify team uses Compass/Sass (a stylesheet meta-language) internally to develop all of our sites. If you are continuing on a build which was started by the team at Mobify you are going to need to install Compass.

Open up a command prompt:

gem update --system
gem install compass

Git

At Mobify, we use Git as the version control software of choice for all our projects. Our projects are hosted on Github.com and are private. If you want to collaborate and troubleshoot with the Mobify team on your codebase, then getting setup with Git is the best way to do that.

Download Github for Windows here

Set up your SSH keys

To hook into our Github repository, you will need to associate your SSH keys with your Github.com account.

Instructions on setting up SSH with GitHub


Mac OS X

Install Node.js

The Mobify Enterprise Client runs a local web server with the development copy of your Mobify bundle. It uses Node.js to run this web server. Version 0.8.21 or newer is required.

Download the latest Node.js here

Install Mobify Enterprise Client

Open Terminal (Applications -> Utilities -> Terminal) to install Mobify Enterprise Client.

sudo npm -g install mobify-client

Recommended Tools

We use the following tools internally at Mobify and recommend them for your development process as well. However, they are not required to develop with Mobify Enterprise Client.

Ruby

Compass requires Ruby. Version 1.87 or newer is required.

If you are on Mac OS X, you probably already have this pre-installed. To check, try checking in Terminal.

ruby -v

Compass/Sass

The Mobify team uses Compass/Sass (a stylesheet meta-language) internally to develop all of our sites. If you are continuing on a build which was started by the team at Mobify you are going to need to install Compass.

Open up a prompt:

sudo gem update --system
sudo gem install compass

Git

At Mobify, we use Git as the version control software of choice for all our projects. Our projects are hosted on Github.com and are private. If you want to collaborate and troubleshoot with the Mobify team on your codebase, then getting setup with Git is the best way to do that.

Download Git command line client here

or

Download Github for Mac client here

Set up your SSH keys

To hook into our Github repository, you will need to associate your SSH keys with your Github.com account.

Instructions on setting up SSH with Github


Linux

Install Node.js

The Mobify Enterprise Client runs a local web server with the development copy of your Mobify bundle. It uses Node.js to run this web server. Version 0.8.21 or newer is required.

Download and compile the Node.js source code

or

Install Node.js via package manager

Install Mobify Client

Open a terminal to install Mobify Client.

sudo npm -g install mobify-client

Recommended Tools

We use the following tools internally at Mobify and recommend them for your development process as well. However, they are not required to develop with Mobify Enterprise Client.

Ruby

Compass requires Ruby. Version 1.87 or newer is required.

Many Linux distributions including Ruby by default. Try checking in your terminal:

ruby -v

If not, install Ruby using your distribution's package management system or by compiling from source:

Instructions on compiling Ruby from source

Compass/Sass

The Mobify team uses Compass/Sass (a stylesheet meta-language) internally to develop all of our sites. If you are continuing on a build which was started by the team at Mobify you are going to need to install Compass.

Open up a terminal:

sudo gem update --system
sudo gem install compass

Git

At Mobify, we use Git as the version control software of choice for all our projects. Our projects are hosted on Github.com and are private. If you want to collaborate and troubleshoot with the Mobify team on your codebase, then getting setup with Git is the best way to do that.

Download Git command line client here

Set up your SSH keys

To hook into our Github repository, you will need to associate your SSH keys with your Github.com account.

Instructions on setting up SSH with GitHub

Last Edited